Old Rock Mustard's Blog: Julho 2010

quinta-feira, julho 29, 2010

Kubuntu Lucid 10.04

Instalação:

Instalei de forma limpa em partição reiserfs dfer 12gb de um HD sata2 de 320GB.

Usando kernel original da dist e drivers de video nvidia-current.

Problema 1:

CPU constantemente a 100%, com efeitos desabilitados e não importa o tipo de aplicação em uso. Xorg root chega a 100%.

Quando chega a cpu a 100% o HD fica congelado e osistema inteiro fica lento até cair o uso do cpu e hd.

--------------------------------------------------------------------------------------------------------------

# nvidia-settings: X configuration file generated by nvidia-settings

# nvidia-settings: version 1.0 (buildd@palmer) Fri Apr 9 10:35:18 UTC 2010

Section "Monitor"

Identifier "Monitor0"

VendorName "Unknown"

ModelName "PBR"

HorizSync 31.5 - 53.7

VertRefresh 60.0 - 85.0

Option "DPMS" "false"

# HorizSync source: edid, VertRefresh source: edid

EndSection

Section "Screen"

Identifier "Screen0"

Device "Device0"

Monitor "Monitor0"

Option "metamodes" "800x600_85 +0+0; 800x600 +0+0"

Option "AddARGBGLXVisuals" "True"

Option "AllowGLXWithComposite" "true"

DefaultDepth 24

SubSection "Display"

Depth 24

EndSubSection

EndSection

Section "Module"

Load "dbe"

Load "extmod"

Load "type1"

Load "freetype"

Load "glx"

EndSection

Section "DRI"

Mode 0666

EndSection

Section "InputDevice"

Identifier "Mouse0"

Driver "mouse"

Option "Device" "/dev/ttyS0"

Option "Protocol" "microsoft"

EndSection

Section "InputDevice"

Identifier "Keyboard0"

Driver "kbd"

Option "XkbRules" "xorg"

Option "XkbModel" "abnt2"

Option "XkbLayout" "br"

EndSection

Section "Extensions"

Option "Composite" "Enable"

EndSection

Section "ServerLayout"

Identifier "Layout0"

Screen 0 "Screen0" 0 0

InputDevice "Keyboard0" "CoreKeyboard"

InputDevice "Mouse0" "CorePointer"

EndSection

Section "Device"

Identifier "Device0"

VendorName "NVIDIA Corporation"

BoardName "GeForce 6150SE nForce 430"

Option "AllowGLXWithComposite" "true"

Driver "nvidia"

Option "NoLogo" "True"

EndSection

Section "ServerFlags"

Option "AllowMouseOpenFail" "true"

EndSection

-----------------------------------------------------------------------------------------------------------------

=-=-=-=-=
Powered by Blogilo

segunda-feira, julho 12, 2010

try 3 - totem-xine in Lucid


with sources.list from karmic:

  • ~$ sudo apt-get update
  • $ sudo apt-get install libtotem-plparser12 libtotem-plparser-dev
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libtotem-plparser-dev: Depends: libglib2.0-dev (>= 2.21.6) but it is not going to be installed
                         Depends: libgtk2.0-dev (>= 2.11.6) but it is not going to be installed
                         Depends: libgmime-2.4-dev but it is not going to be installed
E: Broken packages
  • sudo aptitude -y install libtotem-plparser12 libtotem-plparser-dev
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Reading extended state information     
Initializing package states... Done
The following packages are BROKEN:
  g++-4.4 gcc-4.4 libatk1.0-dev libc-dev-bin libc6-dev libcairo2-dev
  libdirectfb-dev libdirectfb-extra libexpat1-dev libfontconfig1-dev
  libfreetype6-dev libglib2.0-dev libgtk2.0-dev libice-dev libjpeg62-dev
  libpango1.0-dev libpixman-1-dev libpng12-dev libsm-dev libstdc++6-4.4-dev
  libsysfs-dev libx11-dev libxau-dev libxcb-render-util0-dev
  libxcb-render0-dev libxcb1-dev libxcomposite-dev libxcursor-dev
  libxdamage-dev libxdmcp-dev libxext-dev libxfixes-dev libxft-dev
  libxi-dev libxinerama-dev libxrandr-dev libxrender-dev zlib1g-dev
The following NEW packages will be installed:
  binutils{a} build-essential{a} cvs{a} debhelper{a} dpkg-dev{a}
  fakeroot{a} g++{a} gcc{a} gettext{a} html2text{a} intltool-debian{a}
  libgmime-2.4-2{a} libgmime-2.4-dev{a} libmail-sendmail-perl{a}
  libpthread-stubs0{a} libpthread-stubs0-dev{a}
  libsys-hostname-long-perl{a} libtotem-plparser-dev libtotem-plparser12
  linux-libc-dev{a} patch{a} pkg-config{a} po-debconf{a}
  x11proto-composite-dev{a} x11proto-core-dev{a} x11proto-damage-dev{a}
  x11proto-fixes-dev{a} x11proto-input-dev{a} x11proto-kb-dev{a}
  x11proto-randr-dev{a} x11proto-render-dev{a} x11proto-xext-dev{a}
  x11proto-xinerama-dev{a} xtrans-dev{a}
0 packages upgraded, 72 newly installed, 0 to remove and 1 not upgraded.
Need to get 33.5MB of archives. After unpacking 118MB will be used.
The following packages have unmet dependencies:
  libsm-dev: Depends: libsm6 (= 2:1.1.0-2) but 2:1.1.1-1 is installed.
  libice-dev: Depends: libice6 (= 2:1.0.5-1) but 2:1.0.6-1 is installed.
  libatk1.0-dev: Depends: libatk1.0-0 (= 1.28.0-0ubuntu1) but 1.30.0-0ubuntu2 is installed.
  libglib2.0-dev: Depends: libglib2.0-0 (= 2.22.3-0ubuntu1) but 2.24.0-0ubuntu4 is installed.
  libpango1.0-dev: Depends: libpango1.0-0 (= 1.26.0-1) but 1.28.0-0ubuntu2 is installed.
  g++-4.4: Depends: gcc-4.4-base (= 4.4.1-4ubuntu9) but 4.4.3-4ubuntu5 is installed.
  libc-dev-bin: Depends: libc6 (< 2.11) but 2.11.1-0ubuntu7 is installed.
  libxi-dev: Depends: libxi6 (= 2:1.2.1-2ubuntu1) but 2:1.3-3 is installed.
  libxrender-dev: Depends: libxrender1 (= 1:0.9.4-2ubuntu1) but 1:0.9.5-1 is installed.
  libstdc++6-4.4-dev: Depends: gcc-4.4-base (= 4.4.1-4ubuntu9) but 4.4.3-4ubuntu5 is installed.
  libcairo2-dev: Depends: libcairo2 (= 1.8.8-2ubuntu1.1) but 1.8.10-2ubuntu1 is installed.
  libxdmcp-dev: Depends: libxdmcp6 (= 1:1.0.2-3) but 1:1.0.3-1 is installed.
  libsysfs-dev: Depends: libsysfs2 (= 2.1.0-5) but 2.1.0-6 is installed.
  libdirectfb-extra: Depends: libdirectfb-1.2-0 (= 1.2.7-2ubuntu1) but 1.2.8-5ubuntu2 is installed.
  libpng12-dev: Depends: libpng12-0 (= 1.2.37-1ubuntu0.2) but 1.2.42-1ubuntu2 is installed.
  gcc-4.4: Depends: gcc-4.4-base (= 4.4.1-4ubuntu9) but 4.4.3-4ubuntu5 is installed.
           Depends: cpp-4.4 (= 4.4.1-4ubuntu9) but 4.4.3-4ubuntu5 is installed.
  libfontconfig1-dev: Depends: libfontconfig1 (= 2.6.0-1ubuntu12) but 2.8.0-2ubuntu1 is installed.
  libdirectfb-dev: Depends: libdirectfb-1.2-0 (= 1.2.7-2ubuntu1) but 1.2.8-5ubuntu2 is installed.
  libxcursor-dev: Depends: libxcursor1 (= 1:1.1.9-1build1) but 1:1.1.10-1 is installed.
  libxcb-render-util0-dev: Depends: libxcb-render-util0 (= 0.3.6-1) but 0.3.6-1build1 is installed.
  libgtk2.0-dev: Depends: libgtk2.0-0 (= 2.18.3-1ubuntu2.2) but 2.20.1-0ubuntu2 is installed.
  libxext-dev: Depends: libxext6 (= 2:1.0.99.1-0ubuntu4) but 2:1.1.1-2 is installed.
  libjpeg62-dev: Depends: libjpeg62 (= 6b-14build1) but 6b-15ubuntu1 is installed.
  libxdamage-dev: Depends: libxdamage1 (= 1:1.1.1-4) but 1:1.1.2-1 is installed.
  zlib1g-dev: Depends: zlib1g (= 1:1.2.3.3.dfsg-13ubuntu3) but 1:1.2.3.3.dfsg-15ubuntu1 is installed.
  libfreetype6-dev: Depends: libfreetype6 (= 2.3.9-5) but 2.3.11-1ubuntu2 is installed.
  libxau-dev: Depends: libxau6 (= 1:1.0.4-2) but 1:1.0.5-1 is installed.
  libxcomposite-dev: Depends: libxcomposite1 (= 1:0.4.0-4) but 1:0.4.1-1 is installed.
  libxrandr-dev: Depends: libxrandr2 (= 2:1.3.0-2) but 2:1.3.0-3 is installed.
  libexpat1-dev: Depends: libexpat1 (= 2.0.1-4ubuntu1.1) but 2.0.1-7ubuntu1 is installed.
  libc6-dev: Depends: libc6 (= 2.10.1-0ubuntu17) but 2.11.1-0ubuntu7 is installed.
  libpixman-1-dev: Depends: libpixman-1-0 (= 0.14.0-1) but 0.16.4-1ubuntu2 is installed.
  libxft-dev: Depends: libxft2 (= 2.1.13-3ubuntu1) but 2.1.14-1ubuntu1 is installed.
  libx11-dev: Depends: libx11-6 (= 2:1.2.2-1ubuntu1) but 2:1.3.2-1ubuntu3 is installed.
  libxcb-render0-dev: Depends: libxcb-render0 (= 1.4-1) but 1.5-2 is installed.
  libxfixes-dev: Depends: libxfixes3 (= 1:4.0.3-2build1) but 1:4.0.4-1 is installed.
  libxcb1-dev: Depends: libxcb1 (= 1.4-1) but 1.5-2 is installed.
  libxinerama-dev: Depends: libxinerama1 (= 2:1.0.3-2) but 2:1.1-2 is installed.
open: 8197; closed: 4993; defer: 0; conflict: 4                                .Resolving dependencies...
open: 16503; closed: 9997; defer: 0; conflict: 4                               oResolving dependencies...
open: 24801; closed: 14999; defer: 0; conflict: 4                              OResolving dependencies...
open: 33121; closed: 19997; defer: 0; conflict: 4                              OResolving dependencies...
open: 41418; closed: 24997; defer: 0; conflict: 4                              .Resolving dependencies...
open: 49634; closed: 29988; defer: 0; conflict: 4                              oResolving dependencies...
open: 57945; closed: 34989; defer: 0; conflict: 4                              OResolving dependencies...
open: 66257; closed: 39995; defer: 0; conflict: 4                              OResolving dependencies...
open: 74543; closed: 44997; defer: 0; conflict: 4                                                             oResolving dependencies...
open: 82881; closed: 49991; defer: 0; conflict: 4                                                             oResolving dependencies...
open: 91194; closed: 54994; defer: 0; conflict: 4                                                             .Resolving dependencies...
open: 99478; closed: 59994; defer: 0; conflict: 4                                                             OResolving dependencies...
open: 107831; closed: 64995; defer: 0; conflict: 4                                                            oResolving dependencies...
open: 116080; closed: 69984; defer: 0; conflict: 4                                                            OResolving dependencies...
open: 124391; closed: 74999; defer: 0; conflict: 4                                                            oResolving dependencies...
open: 132816; closed: 79992; defer: 0; conflict: 4                                                            oResolving dependencies...
open: 141164; closed: 84992; defer: 0; conflict: 4                                                            oResolving dependencies...
open: 143116; closed: 86176; defer: 0; conflict: 4

  • One hour late still resolving dep...
  • So
  • sudo aptitude -y -f install libtotem-plparser12 libtotem-plparser-dev
seens installed
  • still with KARMIC sources.list

  • sudo apt-get install python-support libglib2.0-dev liblircclient-dev \
libirman-dev gnome-pkg-tools libxine-dev libglade2-dev libxml-parser-perl \
libxml2-dev  gstreamer0.10-tools librsvg2-dev shared-mime-info libhal-dev  \
libssl-dev gtk-doc-tools librsvg2-common iso-codes \
libmusicbrainz4-dev gnome-icon-theme intltool dpkg-dev libx11-dev libcairo2-dev \
libdbus-glib-1-dev autotools-dev libgconf2-dev libgtk2.0-dev \
libxtst-dev libxrandr-dev libxxf86vm-dev gnome-doc-utils python-dev python-xdg \
python-apt python-rdflib python-gtk2-dev python-gobject-dev python-gst0.10 \
python-gdbm libxine1 checkinstall libxine1-ffmpeg libtrackerclient-dev


  •  mkdir totemx_build && cd totemx_build
  • tar xzvf totem-2.26.5.tar.gz
  • cd totem-2.26.5




  • ~/totemx_build/totem-2.26.5$ ./configure --enable-xine --disable-browser-plugins --disable-nautilus --with-plugins=none --disable-shared  --enable-xine --disable-browser-plugins --disable-nautilus --with-plugins=none --disable-shared --disable-schemas-install
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: in `/home/brain/totemx_build/totem-2.26.5':
configure: error: C compiler cannot create executables
See `config.log' for more details.
  • :~/totemx_build/totem-2.26.5$ ./configure --enable-xine --disable-browser-plugins --disable-nautilus --with-plugins=none --disable-shared  --enable-xine --disable-browser-plugins --disable-nautilus --with-plugins=none --disable-shared --disable-schemas-install
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: in `/home/brain/totemx_build/totem-2.26.5':
configure: error: C compiler cannot create executables
See `config.log' for more details.



sábado, julho 03, 2010

Chegou a hora...tchau!!!

Vou cancelar a internet 4mb adeus....  :'(
--   [category linux, Linux - Programas, clima, dia-a-dia, Entretenimento, Música, Memórias] [tags linux, Linux - Programas, clima, dia-a-dia, Entretenimento, Música, Memórias]